Issue with Engage
Resolved·Partial outage

This incident has been resolved.

Mon, Jan 20, 2025, 09:07 PM
(7 months ago)
·
Affected components
Engage
Updates

Resolved

This incident has been resolved.

Mon, Jan 20, 2025, 09:07 PM

Monitoring

We have identified the issue and implemented a fix. This issue has been resolved, however, we will continue to monitor.

Mon, Jan 20, 2025, 05:13 PM(3 hours earlier)

Investigating

We have detected an issue with some Engage functionality around accounts and tasks. As a result, some users may be experiencing slowness when running the application. We are working on identifying the issue and resolving it as soon as possible

Mon, Jan 20, 2025, 10:51 AM(6 hours earlier)
Powered by