CRM update times slower than expected

Incident Report for Gong

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 08:37 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 05:13 PDT

Investigating

CRM updates are currently operating slower than expected for some customers, it's not all of them. We are currently working to address the issue and restore full functionality.
Posted Jun 12, 2025 - 04:38 PDT