Investigating: Degraded performance for some Engage users

Incident Report for Gong

Resolved

This incident has been resolved.
Posted May 27, 2025 - 09:33 PDT

Monitoring

A fix has been implemented and we are currently monitoring!
Posted May 27, 2025 - 08:55 PDT

Investigating

We are aware that some customers are experiencing issues with Engage, specifically with accessing To Do's. We are working to resolve the issue as soon as possible. Please check back for updates.
Posted May 27, 2025 - 08:34 PDT
This incident affected: Engage.