Resolved
The issue has been resolved.
Monitoring
A fix was implemented to restore the Platform, and our team is monitoring the situation.
Investigating
We are aware that some customers are experiencing issues with the Platform.
Investigating
We are aware that some customers are experiencing issues with Engage To-dos. Our team is investigating the issue.