Service disruptions may be experienced temporarily
Resolved·Degraded performance

This incident has been resolved

Wed, Oct 9, 2024, 03:30 PM
(11 months ago)
·
Affected components
Deals and Forecast
Engage
Updates

Resolved

This incident has been resolved

Wed, Oct 9, 2024, 03:30 PM

Identified

We've detected that some customers might currently be experiencing service disruptions. We are analyzing what the issue is at the moment and will update once we know more.

Wed, Oct 9, 2024, 02:24 PM(1 hour earlier)
Powered by