Resolved
The incident has been resolved
Monitoring
We have implemented a fix and are currently monitoring system performance.
Investigating
We are currently investigating an issue affecting the Call page.
Users in the US-hosted environment may experience issues where they are unable to play recorded meetings.
Our engineering teams are actively working to identify the root cause. We will provide another update as soon as more information becomes available.