Resolved
The issue has been resolved.
Monitoring
We have implemented a fix and are currently monitoring system performance.
Investigating
We are currently investigating an issue affecting the Forecast module.
Users may experience issues accessing or using any Forecast features.
We will provide another update as soon as more information is available