Resolved
The system is stable and all services are operating as expected.
Monitoring
We resolved the issue and are monitoring the overall service health.
Identified
We have identified the issue affecting Forecast and Engage.
The issue is related to an upstream service provider. Users may experience technical errors or slower than usual performance when loading these pages. We are currently proceeding with mitigation steps and expect a resolution within the hour.
Investigating
We are currently investigating an issue affecting Forecast and Engage (specifically To-dos and Accounts). Users may experience technical errors or slower than usual performance when loading these pages.
We will provide another update as soon as more information is available.