Resolved
We have confirmed that the fix was successful and website performance has returned to normal.
Monitoring
We have identified the root cause and have implemented a fix.
We are currently monitoring performance and system metrics to ensure load times return to normal stability.
Investigating
We are currently investigating reports of slowness and degraded performance across the website. Users may experience longer load times than usual. Our engineering team is actively looking into the root cause, and we will provide an update as soon as we have more information.
Thank you for your patience.