We are currently experiencing issues with Forecast & Accessing the Team Members Page.
Resolved·Degraded performance

A fix was implemented to restore performance. Forecast & the Team Members page should now be fully accessible. Our team is continuing to monitor the results.

Wed, Aug 27, 2025, 06:06 PM
(5 days ago)
·
Affected components
Deals and Forecast
Updates

Resolved

A fix was implemented to restore performance. Forecast & the Team Members page should now be fully accessible. Our team is continuing to monitor the results.

Wed, Aug 27, 2025, 06:06 PM

Investigating

Some users may be experiencing disruptions to Forecast & accessing the Team Members Page. We are actively working to investigate and address the issue as quickly as possible. We will provide updates as we know more.

Wed, Aug 27, 2025, 04:47 PM(1 hour earlier)
Powered by