CRM update times slower than expected
Resolved

This incident has been resolved.

Thu, Jun 12, 2025, 03:37 PM
(2 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Thu, Jun 12, 2025, 03:37 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Thu, Jun 12, 2025, 12:13 PM(3 hours earlier)

Investigating

CRM updates are currently operating slower than expected for some customers, it's not all of them. We are currently working to address the issue and restore full functionality.

Thu, Jun 12, 2025, 11:38 AM(35 minutes earlier)
Powered by